Excel Wenn Dann

Anzeige

Excel Wenn Dann in mehreren ZeilenDie Excel Wenn Dann Funktion gehört zu den wichtigsten Grundlagen und findet in fast jeder Excel Tabelle eine sinnvolle Verwendung. Natürlich kann sie auch verschachtel werden. In diesem Fall kann Excel Wenn Dann mehrere Bedingungen miteinander kombinieren. Dieser Artikel zeigt Dir alles Notwendige von den Basics bis hin zur Profi-Formel! Ganz unten als Zusammenfassung gibt es dann auch noch ein Videofilm dazu;-)

Kostenlose Beispiele zum Download

Hier erhälst Du ein paar Excel Tabellen mit einfachen und komplexen Beispielen zur Verwendung der Wenn Dann Funktion. In vielen Fällen ist die Verwendung trivial, für manche Situationen solltes Du aber zumindest einmal gesehen haben, wozu diese mächtige Funktion verwendet werden kann. Und Du siehst, wie sie zielführend und sinnvoll programmiert wird. Viel Spaß beim Ausloten der unendlichen Exceltiefen;-)

Syntax der Excel Wenn Dann Formel mit einer Bedingung

Der Aufbau der Wenn Dann Formel

Die Formel dreigeteilt und besteht aus folgenden Parametern:

  • Bedingung
  • Dann
  • Sonst

Die Bedingung ist ein Wahrheitswert.

Wenn die Bedingung WAHR ist dann wird die Formel mit dem Inhalt des “Dann”-Parameters ausgewertet.

Wenn die Bedingung FALSCH ist, dann wird die Formel mit dem Inhalt des “Sonst”-Parameters ausgewertet.

Bedingung

Die Bedingung ist in der Regel eine Prüfung mit folgenden Vergleichsoperatoren,

  • Größer: >
  • Größergleich: >=
  • Kleiner: <
  • Kleinergleich: <=
  • Gleich: =
  • Ungleich: <> … siehe hierzu auch den Beitrag: EXCEL UNGLEICH

kann eine Excel Funktion mit einem WAHR / FALSCH Ergebnis sein

  • ISTBEZUG
  • ISTFEHL, ISTFEHLER, ISTNV
  • ISTGERADE, ISTUNGERADE
  • ISTTEXT, ISTKTEXT, ISTLEER, ISTZAHL, ISTLOG

kann aber auch die Konstanten

  • WAHR
  • FALSCH

enthalten, oder kann mit numerischen Werten belegt werden

  • 0 … bedeutet FALSCH
  • jede andere Zahl … bedeutet WAHR

Hier ein paar Beispiele, die alle WAHR, also nur den “Dann”-Parameter auswerten (für A1 = 3,14; A2 = 10):

  • =WENN(A1<=A2;…)
  • =WENN(WAHR;…)
  • =WENN(A1;…)

Dann

Der “Dann”-Parameter kann alles sein, was in einer Excel Zelle stehen kann und ist üblicher Weise

  • Zahl
  • Text (mit Anführungszeichen: “Das ist ein Dann – Text”)
  • Formel (ohne Istgleich-Zeichen: 1+3+$C7)

wie zum Beispiel

  • =WENN(…;3,14;…)
  • =WENN(…;”Otto Mustermann”;…)
  • =WENN(…;A3*A4+17;…)

Sonst

Dieser Parameter entspricht in der Regel dem “Dann”-Parameter.

Der “Sonst”-Parameter kann aber auch gegebenenfalls entfallen. Sofern er in diesem Fall zur Auswertung kommt, liefert er den Wert FALSCH zurück. Für diesem Fall schaut ein sinnvolles Beispiel wie folgt aus:

  • =WENN(A1=A2;WAHR)

Syntax der Excel Formel Wenn Dann mit mehreren Bedingungen

Es gibt einige Fälle, in denen die simple Option JA / NEIN nicht ausreicht. Oft gibt es einen Auswertungswunsch wie JA / VIELLEICHT / NEIN. Oft ist zu überprüfen, ob ein Wert in einem Intervall liegt, oder ob er kleiner oder größer ist. Und es gibt noch viele viele Beispiele, in denen die einfache Wenn Dann Formel nicht mehr ausreicht.

Die Formeln werden hier oft ziemlich lang, hier ein paar Tipps zur besseren Handhabung:

Hier gibt es zwei unterschiedliche Herangehensweisen:

  1. Verwendung einer verschachtelten Bedingung
  2. Verwendung einer verschachtelten Wenn Dann Formel

Punkt 1 ist übersichtlicher, Punkt 2 ist besser!

Anzeige

Im Kapitel Downloads gibt es gute Beispiele hierfür kostenlos zum Herunterladen.

Der Aufbau der verschachtelten Bedingung

Die Verwendung einer verschachtelten Bedingung überprüft eine sehr präzise Aussage, wie zum Beispiel

  • liegt der überprüfte Wert zwischen 20 und 100 und ist er ungerade
  • liegt der überprüfte Wert zwischen 3,1 und 4,2 oder 6,1 und 8,2
  • ist der überprüfte Wert eine Zahl oder ein Text

In diesem Fall muss gekonnt mit den logischen Funktionen

  • UND(Wahrheitswert1; Wahrheitswert2; …)
  • ODER(Wahrheitswert1; Wahrheitswert2; …)
  • NICHT(Wahrheitswert)

umgegangen werden. Die Funktion NICHT kehrt den Wahrheitswert um:

  • NICHT(WAHR) ergibt ganz einfach: FALSCH

Die Auswertung für das Feld D3 der Beispiele von oben wäre:

  • UND(D3>20;D3<100;ISTGERADE(D3))
  • ODER(UND(D3>3,1;D3<4,1);UND(D3>6,1;D3<8,2))
  • ODER(ISTZAHL(D3);ISTTEXT(D3))

Der Aufbau der verschachtelten Wenn Dann Formel

Diese Lösung ist dann sehr sinnvoll, wenn das Ergebnis nicht aus zwei Antworten (WAHR / FALSCH), sondern drei oder mehr Antworten bestehen soll.

In diesen Fall ist eine disziplinierte Verwendung der Wenn Dann Funktion wie folgt empfohlen:

Die untergeordnete Wenn-Dann-Formel sollte immer den “Dann”-Parameter der übergeordneten Wenn-Dann-Formel einnehmen. Diese Form der Verschachtelung kann beliebig oft ausgeführt werden, ein natürliche Grenze bildet die Bedingung, dass eine Formel maximal 8.192 Zeichen beinhalten darf.

 

 

Typische Fehler

Typische Fehler gibt es bei dieser Funktion nicht viele. Bei der Verwendung solltest Du aber stets auf folgende Punkte achten:

  • Soll der Rückgabewert ein Text sein, so ist dieser immer unter Anführungszeichen zu setzten. Die Formel =WENN(1=1;eins gleich eins) liefert den Fehler #NAME?. Korrekt wäre =WENN(1=1;”eins gleich eins”)
  • Soll der Rückgabewert ein Wahrheitswert sein, so ist dieser nie unter Anführungszeichen zu setzten. Die Formel =WENN(1=1;”WAHR”;”FALSCH”) liefert den den Text WAHR, nicht den Wahrheitswert WAHR! Korrekt wäre =WENN(1=1;WAHR;FALSCH)
  • Beachte den unterschied von < und <= sowie > und >=. Oft ist es entscheidend, ob die Intervall-Grenzen mitgenommen werden müssen oder nicht!
  • Achte auf das Format der Zelle, in der die Funktion steht. Das Ergebnis ist natürlich auch in diesem Format. Probleme gibt es schnell beim Mischen von Zahlen-, Datums- und Textformatierungen!

WENNFEHLER – eine nahe verwandte Excelfunktion

Excel kennt neben der Standard-Funktion =WENN(…) noch die sehr ähnliche Funktion =WENNFEHLER(…). Die Verwendung dieser Funktion ist sinnvoll, wenn in einer Tabelle sämtliche Fehlermeldungen durch “lesbare” Ausdrücke ersetzt werden sollen.

Beide Funktionen arbeiten sehr ähnlich, die Funktion WENNFEHLER kontrolliert in der “Bedingung”, ob eine spezielle Zelle oder Formel eine Fehlermeldung vom Typ #NV, #WERT!, #BEZUG!, #DIV/0!, #ZAHL!, #NAME? oder #NULL! zurückgibt. Ist dies der Fall, wird der “Dann”-Parameter ausgewertet. Der “Sonst”-Parameter entfällt immer.

 Zusammenfassung

Hier findest Du einen kurzen Film, in dem die Verwendung der Wenn Dann Formel in der Praxis demonstriert wird. Du siehst ein Beispiel für die Grundformel und die Berücksichtigung mehrer Bedingungen.

Jetzt bist Du dran

Anzeige

Natürlich gäbe es noch viel mehr zu sagen und natürlich gibt es noch sehr viel mehr zu fragen; in diesem Sinne freue ich mich über jede positive und / oder kritische Rückmeldung – Du entscheidest, wie sich diese Seite letztendlich weiter entwickelt, welche Themen behandelt werden und in welcher Form die Beiträge dokumentiert werden (mehr Beispiele, bessere ToDo-Skizzen, ausführlichere Erläuterungen, mehr Links zu weiterführenden Seiten usw.) – also los geht’s …

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.